Re: [R] R CMD check fails at package dependencies check on Fedora Core 5, works on other systems

From: Robert King <Robert.King_at_newcastle.edu.au>
Date: Tue 19 Sep 2006 - 10:02:08 GMT

No output from the tools command

Peter Dalgaard wrote:

> Robert King <Robert.King@newcastle.edu.au> writes:
> 

>> I'm testing a FC5 machine for use in a student lab. R 2.3.1 is installed and
>> seems to work fine. There is one peculiarity - the logins are authenticating
>> to a server, and a "verbose" flag is set somewhere, leading to lots of
>> spurious messages like this
>>
>> request done: ld 0xa227598 msgid 1
>>
>> which may be confusing R.
>>
>> However, R CMD check seems to fail for packages with no dependencies at the
>> dependencies check stage.
>>
>> I've tried this with two packages, my own gld and also zipfR. Both fail in
>> the same way.
>>
>> [Desktop]$ R CMD check zipfR_0.6-0.tar.gz
>> * checking for working latex ... OK
>> request done: ld 0x8dfb170 msgid 1
>> request done: ld 0x8dfb170 msgid 2
>> * using log directory '/home/rak776/Desktop/zipfR.Rcheck'
>> * using Version 2.3.1 (2006-06-01)
>> * checking for file 'zipfR/DESCRIPTION' ... OK
>> * checking extension type ... Package
>> * this is package 'zipfR' version '0.6-0'
>> * checking package dependencies ... ERROR
>> [Desktop]$ R CMD check gld
>> * checking for working latex ... OK
>> * using log directory '/home/rak776/Desktop/gld.Rcheck'
>> * using Version 2.3.1 (2006-06-01)
>> * checking for file 'gld/DESCRIPTION' ... OK
>> * this is package 'gld' version '1.8'
>> * checking package dependencies ... ERROR
>>
>> Both these work on two other systems - one a debian/sarge AMD64 and a
>> debian/sarge i386
> 
> And at least the former is quite happy on a vanilla FC5/ R2.3.1
> 
> What happens if you fire up R --quiet and submit
> 
>  tools:::.check_package_depends("zipfR")
> 
> (after unpacking the tarball, of course)? This gives no output for me.

Similarly, no output

>> A package with dependencies checks for dependencies correctly - for example
>> ade4:
>>
>> Desktop]$ R CMD check ade4_1.4-1.tar.gz
>> * checking for working latex ... OK
>> request done: ld 0x994b168 msgid 1
>> request done: ld 0x994b168 msgid 2
>> request done: ld 0x994b168 msgid 3
>> * using log directory '/home/rak776/Desktop/ade4.Rcheck'
>> * using Version 2.3.1 (2006-06-01)
>> * checking for file 'ade4/DESCRIPTION' ... OK
>> * this is package 'ade4' version '1.4-1'
>> * checking package dependencies ... ERROR
>> request done: ld 0xa458598 msgid 1
>> request done: ld 0xa458598 msgid 2
>> request done: ld 0xa458598 msgid 3
>> Packages required but not available:
>> waveslim splancs maptools spdep pixmap ape tripack
>>
>> Does anyone have ideas on what is going wrong?
>>
>> Regards,
>> Robert King



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue Sep 19 20:21:00 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 19 Sep 2006 - 12:30:05 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.