[R] problem installing RdbiPgSQL for 2.4

From: Oleg Bartunov <oleg_at_sai.msu.su>
Date: Tue 03 Oct 2006 - 14:55:13 GMT


I just upgraded R to version 2.4.0 and now I can't install packages RdbiPgSQL. I used the same procedure I did for previous versions of R ! Actually, last time I installed RdbiPgSQL day before upgrading but now I got:

downloaded 27Kb

I could not find your PostgreSQL client libraries! Use --with-pgsql-libraries=PATH; if running R's INSTALL, use --configure-args='--with-pgsql-libraries=PATH'; or set PG_LIB_DIR in your environment to the library path, and rerun the configure/install.

ERROR: configuration failed for package 'RdbiPgSQL' ** Removing '/usr/local/lib/R/library/RdbiPgSQL'

The downloaded packages are in

         /tmp/RtmpA3Mdb4/downloaded_packages Warning message:
installation of package 'RdbiPgSQL' had non-zero exit status in: install.packages("RdbiPgSQL", repos = rS, configure.args = c(PGSQL = "--with-pgsql-libraries=/usr/local/pgsql/lib --with-pgsql-includes=/usr/local/pgsql/include"))

Looks like install.packages doesn't pass configure.args to the package.

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, Research Scientist, Head of AstroNet (www.astronet.ru), Sternberg Astronomical Institute, Moscow University, Russia Internet: oleg_at_sai.msu.su, http://www.sai.msu.su/~megera/ phone: +007(495)939-16-83, +007(495)939-23-83

R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Wed Oct 04 01:03:24 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 03 Oct 2006 - 18:30:06 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.