Re: [R] [Mac OS X 10.4] object R_loess_raw not found (reason found)

From: René J.V. Bertin <rjvbertin_at_gmail.com>
Date: Mon 09 Oct 2006 - 15:36:34 GMT


Well... this may be a red herring after all, but it's an interesting one!

It turns out I have got DYLD_LIBRARY_PATH set. This gets exported to R (or rather, affects the loader that loads the R process?), and somehow mixes up the way symbols are exported. Something that applies to launching R from the command line (/usr/bin/R) AND via LaunchServices (open -a R). Once I noticed that invoking the R GUI like that also provoked the issue, I quickly understood that something in the environment must be involved.

Unsetting DYLD_LIBRARY_PATH restores normal behaviour.

Note that this never caused any problems on 10.3 (and I'm not completely convinced there hasn't been a recent update to dyld that may be the culprit).

I still don't understand how this could make a symbol unavailable that is stored in some sort of internal registry.

However, while rebuilding 2.3.1 from source (!, but this one worked for me), I did notice that the configure script doesn't correctly detect that gcc-4.0 knows of the visibility attributes. This *may* somehow be related.

On 09/10/06, René J.V. Bertin <rjvbertin@gmail.com> wrote:
> To make things even weirder, everything seems to work just fine when I
> launch R via the v1.17 3878 build of the R GUI for 2.4 ...
>



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue Oct 10 01:45:05 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Mon 09 Oct 2006 - 20:30:29 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.