Re: [R] Unable to load foreign after upgrade on ubuntu

From: Dirk Eddelbuettel <edd_at_debian.org>
Date: Tue 24 Oct 2006 - 16:50:08 GMT

On 24 October 2006 at 16:30, Prof Brian Ripley wrote:
| On Tue, 24 Oct 2006, Dirk Eddelbuettel wrote:
| > There are interdependencies between the R binary and the dynamically loaded
| > libraries it loads. By upgrading R, you have agreed to the Faustian bargain
| > of potentially having to upgrade these libraries too.
| >
| > So reinstalling foreign from CRAN should do. R can do that for you, see
| > help("update.packages")
| > and make sure you also have r-base-dev installed as this will cover most if
| > not all of the tools
|
| But since foreign is part of R, installing a new version of R will update
| the standard and recommended packages including foreign. So this suggests
| that what is being picked up is another copy of foreign from another
| library.

Good point.

As I recall, Christian always builds a sumo 'r-recommends' package which Bjorn should install from the same apt-get'able archive on CRAN.

Dirk

-- 
Hell, there are no rules here - we're trying to accomplish something. 
                                                  -- Thomas A. Edison

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Wed Oct 25 02:54:40 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 24 Oct 2006 - 17:30:13 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.