[R] quantreg and sparseM will not load

From: <S.Hodgkinson_at_brighton.ac.uk>
Date: Mon, 21 May 2007 19:22:21 +0100


I have recently started using R and want to use the quantreg (and sparseM) packages.

I downloaded the .tar files for each, and placed the subsequent folders into the library folder in the frameworks/R.framework/ resources/library folder with all the other packages.

When I try to load either package from the package manager window I get:

Loading required package: SparseM
Error in dyn.load(x, as.logical(local), as.logical(now)) :

        unable to load shared library '/Library/Frameworks/R.framework/ Versions/2.4/Resources/library/SparseM/libs/i386/SparseM.so':

   dlopen(/Library/Frameworks/R.framework/Versions/2.4/Resources/ library/SparseM/libs/i386/SparseM.so, 6): Library not loaded: / Library/Frameworks/R.framework/Versions/2.5/Resources/lib/libgfortran. 2.dylib

   Referenced from: /Library/Frameworks/R.framework/Versions/2.4/ Resources/library/SparseM/libs/i386/SparseM.so

   Reason: image not found
In addition: Warning messages:
1: package 'quantreg' was built under R version 2.5.0 2: package 'SparseM' was built under R version 2.5.0

any ideas? I assumed at first that sparseM was required for quantreg but neither will load.

Regards

Steve Hodgkinson



R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Mon 21 May 2007 - 18:32:07 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 21 May 2007 - 19:30:58 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.