Re: [R] installing problems

From: dohyedan <djhayes_at_liv.ac.uk>
Date: Thu, 31 May 2007 05:10:15 -0700 (PDT)

Would like to share that I am having the exact same problem running on Ubuntu 7.04 trying to install the R-2.5.0.tar.gz file

After trying './configure' I also get the same error message: configure: error: --with-readline=yes (default) and headers/libs are not available

Hope some one can help us out on this one Cheers,
Daniel

Xyoby Chavez wrote:
>
> hi every body.
>
> Im new in this program. Im traying to install R in linux suse10.0 in
> two following form:
>
> a) with the file R-2.5.0.tar.gz
>
> b) and the rpm file : R-base-2.5.0-2.1.i586.rpm
>
> ****** In the first case a) when i uncompressed and type:
>
> linux:/opt/R/R-2.5.0 # ./configure
>
> the followind message is showed
>
>
> linux:/opt/R/R-2.5.0 # ./configure
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> loading site script './config.site'
> loading build specific script './config.site'
> checking for pwd... /bin/pwd
> checking whether builddir is srcdir... yes
> .
> .
> .
> checking for dlopen in -ldl... yes
> checking readline/history.h usability... no
> checking readline/history.h presence... no
> checking for readline/history.h... no
> checking readline/readline.h usability... no
> checking readline/readline.h presence... no
> checking for readline/readline.h... no
> checking for rl_callback_read_char in -lreadline... no
> checking for main in -lncurses... yes
> checking for rl_callback_read_char in -lreadline... no
> checking for history_truncate_file... no
> configure: error: --with-readline=yes (default) and headers/libs are
> not available
> linux:/opt/R/R-2.5.0 #
>
> after that i try to do :
>
> linux:/opt/R/R-2.5.0 # make
> make: *** No targets specified and no makefile found. Stop.
>
> i installed : xorg-x11-devel and libpng-devel , suggested by
> somebody
> and nothing.
>
> ******Affter with b) tray to install with the YAST. It installed
> without errors, but when i try to run R the following message is
> showed:
>
> /usr/lib/R/bin/exec/R: error while loading shared libraries:
> libgfortran.so.0: cannot open shared object file: No such file or
> directory
>
> then i do
>
> linux:/usr/lib # ln /opt/gnat/lib/libgfortran.so libgfortran.so.0
>
> it also doesnt work.
>
> Thanks for yor help
>
> Xyoby Chavez P
> Lima Peru
>
> ______________________________________________
> R-help_at_stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>
>

-- 
View this message in context: http://www.nabble.com/installing-problems-tf3806626.html#a10892609
Sent from the R help mailing list archive at Nabble.com.

______________________________________________
R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Thu 31 May 2007 - 12:19:32 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 31 May 2007 - 13:31:39 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.