Re: [R] update packages with R on Vista: error

From: Stefan Grosse <singularitaet_at_gmx.net>
Date: Thu, 07 Jun 2007 15:36:24 +0200

Actually the packages R wants to update are: VR, cluster, lattice, mgcv, nlme and rcompgen. I did how described in the R-Win-FAQ create a .Renviron File containing the path to the win-library that R already created (R_LIBS=C: ... ). I also tried to add R_LIBS= as Rgui parameter from within Tinn-R. Additionally I tried to leave a file named Renviron.site in the etc library. Nothing worked thus far.

Interestingly installing packages does work fine even without specifying the R_LIBS path manually with any of the above mentioned methods.

Even more puzzling is that even when I install eg. nlme manually via install.packages("nlme") it works but R still wants to update it. Even though e.g. library(nlme), ?nlme shows that the latest version is installed.

I would guess there is some problem with the library path variable in the update program...

Stefan


R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Thu 07 Jun 2007 - 13:41:31 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 07 Jun 2007 - 22:31:41 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.