[R] character to time problem

From: John Kane <jrkrideau_at_yahoo.ca>
Date: Thu, 07 Jun 2007 17:17:39 -0400 (EDT)


I am trying to clean up some dates and I am clearly doing something wrong. I have laid out an example that seems to show what is happening with the "real" data. The coding is lousy but it looks like it should have worked.

Can anyone suggest a) why I am getting that NA appearing after the strptime() command and b) why the NA is disappearing in the sort()? It happens with na.rm=TRUE and na.rm=FALSE



aa <- data.frame( c("12/05/2001", " ", "30/02/1995", NA, "14/02/2007", "M" ) )
names(aa) <- "times"
aa[is.na(aa)] <- "M"
aa[aa==" "] <- "M"
bb <- unlist(subset(aa, aa[,1] !="M"))
dates <- strptime(bb, "%d/%m/%Y")
dates
sort(dates)

Session Info
R version 2.4.1 (2006-12-18)
i386-pc-mingw32

locale:

LC_COLLATE=English_Canada.1252;
LC_CTYPE=English_Canada.1252;
LC_MONETARY=English_Canada.1252;
LC_NUMERIC=C;LC_TIME=English_Canada.1252

attached base packages:
[1] "stats"     "graphics"  "grDevices" "utils"    

"datasets" "methods" "base"

other attached packages:
  gdata Hmisc
"2.3.1" "3.3-2"

 (Yes I know I'm out of date but I don't like upgrading just as I am finishing a project)

Thanks



R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Thu 07 Jun 2007 - 21:31:17 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 08 Jun 2007 - 00:31:45 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.