[R] survreg error

From: Devarajan, Karthik <Karthik.Devarajan_at_fccc.edu>
Date: Tue, 26 Jun 2007 14:38:52 -0400


Hello,

I am using survreg for a simulation where data is randomly generated from a Weibull distribution and the model parameters estimated. When this is embedded within a loop and the process repeated for different datasets, the program aborts after a few runs in most cases giving the following message:

Error in survreg.fit(X, Y, weights, offset, init = init, controlvals = control, :

        NA/NaN/Inf in foreign function call (arg 9) In addition: Warning message:
no non-missing arguments to max; returning -Inf

I'm having similar problems when using the lognormal distribution as well. Does anyone have any suggestions\thoughts on how to circumvent this issue? I've tried a few things with setting the seed for the random generation without success.

Thanks,
K  

        [[alternative HTML version deleted]]



R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue 26 Jun 2007 - 19:01:27 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 26 Jun 2007 - 23:32:32 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.