Re: [R] Data sets with usage in documentation object but not in code

From: Jonathan Weeks <weeksjp_at_gmail.com>
Date: Fri, 30 Nov 2007 10:29:09 -0700

The file is attached.

Also, to restate what I said earlier. The package passes the checks without any errors or warnings under R 2.5, but now that it is running under 2.6.1 I get a warning (no errors) about having .Rd files without associated .R files (the datasets are in an .RData file in the data subdirectory). Since the only difference is the version of R, I am not sure what I should be doing differently (i.e. do I need to specify something else in the NAMESPACE, etc.)

Thanks again for your help

On Nov 30, 2007 10:18 AM, Martin Maechler <maechler_at_stat.math.ethz.ch> wrote:

> >>>>> "JW" == Jonathan Weeks <weeksjp@gmail.com>
> >>>>> on Fri, 30 Nov 2007 08:46:50 -0700 writes:
>
> JW> Thank you both for your help. I still don't know what is happening.
> I
> JW> uploaded my package (plink_0.0-3) to
> ftp://cran.r-project.org/incoming
>
> That's a place NOBODY can get it - but the CRAN maintainers,
> and they are not very pleased to see a package there which does
> not pass R CMD check.
>
> Please use a different place!
> If you cannot, please
> copy-paste one of the *.Rd files into an e-mail (reply to this).
>
> Martin Maechler, ETH Zurich
>
> JW> If you have any other suggestions they would be greatly appreciated
>
> JW> Take care
>
> JW> Jon
>
> JW> On Nov 29, 2007 10:30 AM, Peter Dalgaard <P.Dalgaard_at_biostat.ku.dk>
> wrote:
>
> >> Prof Brian Ripley wrote:
> >> > On Thu, 29 Nov 2007, Jonathan Weeks wrote:
> >> >
> >> >
> >> >> All,
> >> >>
> >> >> I recently made some changes to my package and ran R CMD check,
> but I
> >> >> am getting a warning regarding my data sets.
> >> >>
> >> >> I am running R 2.6.1 I have an image (.RData) file containing
> five
> >> >> data sets in the data subdirectory and an .Rd file for each of
> the
> >> >> data sets in the man subdirectory. When I run the check I get the
> >> >> warning
> >> >> "Data sets with usage in documentation object <dataset name> but
> not
> >> >> in code" for each dataset. I did not get this warning with R 2.5
> >> >>
> >> >> Does anyone have a suggestion for how to handle this?
> >> >>
> >> >
> >> > Show us a small reproducible example, or (failing that) make the
> package
> >> > available for test? It's hard to guess at the cause, and hundreds
> of
> >> > packages do similar things.
> >> >
> >> >
> >> You could also look at the output of
> >>
> >> tools:::list_data_in_pkg("yourPkg")
> >>
> >> and see if it makes you any wiser. (AFAICS, this is the list that
> the
> >> usage lines get compared to)
> >>
> >> --
> >> O__ ---- Peter Dalgaard ุster Farimagsgade 5, Entr.B
> >> c/ /'_ --- Dept. of Biostatistics PO Box 2099, 1014 Cph. K
> >> (*) \(*) -- University of Copenhagen Denmark Ph: (+45)
> >> 35327918
> >> ~~~~~~~~~~ - (p.dalgaard_at_biostat.ku.dk) FAX: (+45)
> >> 35327907
> >>
>
> JW> [[alternative HTML version deleted]]
>
> JW> ______________________________________________
> JW> R-help_at_r-project.org mailing list
> JW> https://stat.ethz.ch/mailman/listinfo/r-help
> JW> PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html<http://www.r-project.org/posting-guide.html>
> JW> and provide commented, minimal, self-contained, reproducible code.
>



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Fri 30 Nov 2007 - 17:33:49 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 30 Nov 2007 - 18:30:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.