[R] OS-dependent behaviour of strucchange?

From: Michael Lundholm <michael.lundholm_at_ne.su.se>
Date: Wed, 12 Dec 2007 15:07:30 +0100


Using the following code:

library(strucchange)
load(file="y.rda")
ar1<-formula(y~lag(y,k=-1))
plot(Fstats(ar1))

(where the the data file can be downloaded from www.ne.su.se/~mlu/downloads/y.rda) I have a problem replicating identical plots on different implementations of R for different operating systems; I get completely different results under Debian Linux compared to Windows XP.

I have tested three different Windows XP desktops running R 2.6.1 (one) or 2.6.0 (two) and two different Debian Linux desktops running R 2.6.1. In all cases strucchange was version 1.3-2. The Windows desktops all produced the same result (see the file windows.ps available at the same address as the data). The Linux desktops also all produced identical results (the file linux.ps also on the same address) although this was different from that produced by the Windows desktops. Testing the different desktops we made sure that we used exactly the same code and data files.

Completely lost about the possible cause and therefore grateful for any advice,

/Michael Lundholm

-- 
Docent Michael Lundholm
http://www.ne.su.se/~mlu

Reclaim Your Inbox!
http://www.mozilla.org/products/thunderbird

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Wed 12 Dec 2007 - 14:08:54 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 12 Dec 2007 - 14:30:18 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.