Re: [R] Another problem with encoding

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Mon, 31 Dec 2007 10:45:25 +0100

Matthias Wendel wrote:
> Hi
> I've imported an spss-file using read.spss. One variable has value like '─rzte'. I thought this is UTF-8 encoded, but it is not
> (as the results of iconv and utf8ToInt suggest). Is there any way to find out how these spss-values are encoded?
>
You are assuming a bit much of your readers.

What exactly are you doing? Is it a value, a value label, or perhaps a variable name. How do the results of read.spss look on the R side? How did you apply iconv and utf8ToInt? What is your locale?

I mean, we could try and guess all those details, but you are the one with the hard info, and the motivation...

-- 
   O__  ---- Peter Dalgaard             ěster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard_at_biostat.ku.dk)                  FAX: (+45) 35327907

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Mon 31 Dec 2007 - 09:47:21 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 31 Dec 2007 - 10:30:21 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.