[Rd] Outdated dependencies and install.packages()

From: Peter Dalgaard <P.Dalgaard_at_biostat.ku.dk>
Date: Wed, 20 Aug 2008 12:30:19 +0200

This looks like a buglet:

> install.packages("lme4", depend=TRUE, lib="~/Rlibrary/")
--- Please select a CRAN mirror for use in this session --- [...snip...]
** preparing package for lazy loading
Error: package 'Matrix' 0.999375-4 was found, but >= 0.999375.11 is required by 'lme4'
Execution halted
ERROR: lazy loading failed for package 'lme4' ** Removing '/home/bs/pd/Rlibrary/lme4'
** Restoring previous '/home/bs/pd/Rlibrary/lme4'

and the DESCRIPTION file for lme 4 does have

Depends: methods, R(≥ 2.7.0), Matrix(≥ 0.999375-11), lattice <http://cran.r-project.org/web/packages/lattice/index.html>

Looks like we're either not checking the version requirement of dependencies, or something is making 4 > 11... (from my reading of the code, it is the former, but I could have missed something).

We should at least document the behaviour.

   O__  ---- Peter Dalgaard             Øster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark      Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard_at_biostat.ku.dk)              FAX: (+45) 35327907

R-devel_at_r-project.org mailing list
Received on Wed 20 Aug 2008 - 10:40:04 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 20 Aug 2008 - 15:37:09 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive