Re: [R] Plot error

From: <Richard.Cotton_at_hsl.gov.uk>
Date: Fri, 4 Jan 2008 12:04:49 +0000


> I'm trying to plot an svm model and I'm the following error:
>
> > plot(model, data= dados[,-1], formula=formula(dados[,2]~dados[,
> 3]),svSymbol = 1, dataSymbol = 2, symbolPalette = rainbow(4),color.
> palette = terrain.colors)
> Error in terms.default(x) : no terms component
>
> Anyone knows how to solve this???

Asking the same question over and over again doesn't make it easier for us to help you. Also, it is good form to point out which package you are using (I presume this is svm in package e1071).

Please can you provide a reproducible example? (We don't have access to the dados data.)
In the meantime, try typing traceback() after you get the error to see where the problem is. Or, even better, install the debug package and step through your code using mtrace.

Regards,
Richie.

Mathematical Sciences Unit
HSL



ATTENTION: This message contains privileged and confidential inform...{{dropped:20}}

R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Fri 04 Jan 2008 - 12:12:26 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sun 06 Jan 2008 - 12:30:05 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive