[R] Problem using ROracle

From: Shuping Zhang <SZhang_at_ibasis.net>
Date: Mon, 14 Jan 2008 16:50:08 -0500


Hi,  

I am trying to use ROracle installed on a Solaris (i386 platform) with Oracle client 10.2. The installation took quite some troubleshooting, but eventually I could load ROracle library from R, but here is the trace and error:  

> library(ROracle)

Loading required package: DBI

> drv<-dbDriver("Oracle")

> con<-dbConnect(drv,"username/password_at_dbname")

Error in oraNewConnection(drv, ...) :

 RS-DBI driver: (ORA-12154: TNS:could not resolve the connect identifier specified)  

However, when I try to connect to oracle thru sqlplus, I have no problem:  

sqlplus username/password_at_dbname  

would work, I could retrieve data from the database.  

By google this error, I was trying everything in TNSNAMES.ORA file, I tried a numeric ip, tried directly copy the connection string from TNSNAMES.ORA, none seems to work.  

Also, error messages will be recorded in sqlnet.log if I use sqlplus and intentionally use a wrong connection string. But with the ROracle error message above, it is not recoded in sqlnet.log.  

Can some guru help?  

Thanks I advance.  

Shuping Zhang

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Mon 14 Jan 2008 - 21:54:04 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 14 Jan 2008 - 22:30:07 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive