Re: [R] problems with .svg

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Thu, 24 Jan 2008 17:12:04 +0000 (GMT)

I suspect you have ignored

   'If you are using an old version of R and think it does not work    properly, upgrade to the latest version and try that, before posting.'

(from the posting guide). You didn't tell us your R version (as we asked in the posting guide) and so we have assumed it was the latest version given that quote.

RSvgDevice needs R >= 2.6.0, as

http://cran.at.r-project.org/src/contrib/Descriptions/RSvgDevice.html

shows (linked from the page quoted below).

Please do update your R if it is earlier.

On Thu, 24 Jan 2008, Mag. Ferri Leberl wrote:

> Dear everybody,
> I still didn't manage to install the RSvgDevice-Package. Please, note
> the attached file: The server cannot seriousely be the problem. I would
> be glad if you could find the mistake.
> Thank you in advance.
> Yours,
> Mag. Ferri Leberl
>
>
>
> Am Sonntag, den 20.01.2008, 18:29 +0000 schrieb Prof Brian Ripley:
>> On Sun, 20 Jan 2008, Mag. Ferri Leberl wrote:
>>
>>> The program does not open the interface again to select am mirror.
>>> Neither works
>>>
>>> install.packages("RSvgDevice", dependencies = TRUE,
>>> repos="http://cran.r-project.org",contriburl="http://cran.r-project.org")
>>>
>>> the feedback here is
>>>
>>> Warnung in install.packages("RSvgDevice", dependencies = TRUE, repos =
>>> "http://cran.r-project.org", :
>>> argument 'lib' is missing: using
>>> '/home/nemo/R/i486-pc-linux-gnu-library/2.5'
>>> Warnung: unable to access index for repository http://cran.r-project.org
>>> Warning message:
>>> package ‘RSvgDevice’ is not available in: install.packages("RSvgDevice",
>>> dependencies = TRUE, repos = "http://cran.r-project.org",
>>>
>>> What is going wrong?
>>
>> You incorrectly specified contriburl: you only need repos, and giving
>> contriburl incorrectly is the reason for the message you got.
>>
>> I suspect chooseCRAN mirror() failed because the CRAN master was
>> inaccessible: it has been from here on and off all day. In which case you
>> will need to select a different mirror.
>>
>>> Yours, Leberl
>>>
>>>
>>>
>>> Am Sonntag, den 20.01.2008, 16:34 +0100 schrieb Gabor Csardi:
>>>
>>>> Yes, try another mirror. Austria should work. Or go to
>>>> http://cran.at.r-project.org/src/contrib/PACKAGES.html
>>>> and download the package directly and install it via
>>>>
>>>> R CMD INSTALL <package_file>
>>>>
>>>> You might need to give the '-l' options for where to install to.
>>>>
>>>> G.
>>>>
>>>> On Sun, Jan 20, 2008 at 03:49:22PM +0100, Mag. Ferri Leberl wrote:
>>>>> Thank you so far.
>>>>> install.packages("RSvgDevice", dependencies = TRUE)
>>>>>
>>>>> returns
>>>>>
>>>>> Warnung in install.packages("RSvgDevice", dependencies = TRUE) :
>>>>> argument 'lib' is missing: using '/usr/local/lib/R/site-library'
>>>>> Warnung in install.packages("RSvgDevice", dependencies = TRUE) :
>>>>> 'lib = "/usr/local/lib/R/site-library"' is not writable
>>>>> Would you like to create a personal library
>>>>> '~/R/i486-pc-linux-gnu-library/2.5'
>>>>> to install packages into? (y/n) y
>>>>> --- Please select a CRAN mirror for use in this session ---
>>>>> Loading Tcl/Tk interface ... done
>>>>> Warning message:
>>>>> package ‘RSvgDevice’ is not available in: install.packages("RSvgDevice",
>>>>> dependencies = TRUE)
>>>>>
>>>>> When asked I chose for the Bamberg-mirror.
>>>>> Can you recognize a mistake? Should I chose for a different mirror?
>>>>> Thank you in advance.
>>>>> Yours, Mag. Ferri Leberl
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Am Montag, den 14.01.2008, 19:21 +0100 schrieb Gabor Csardi:
>>>>>
>>>>> Are you sure this is an R problem? I guess it is not, but
>>>>> rather a pstoedit problem.
>>>>>
>>>>> You can use the RSVGDevice package, or the Cairo package to
>>>>> export your graphics directly into SVG from R.
>>>>>
>>>>> Gabor
>>>>>
>>>>> On Mon, Jan 14, 2008 at 07:10:13PM +0100, Mag. Ferri Leberl wrote:
>>>>> > Dear everybody!
>>>>> > I am making a graph in R and employ pstoedit to expot the .pdf-output
>>>>> > to .svg.
>>>>> > When I open the .svg with firefox I get the .svg-code shown wit the
>>>>> > following header:
>>>>> > "Mit dieser XML-Datei sind anscheinend keine Style-Informationen
>>>>> > verknüpft. Nachfolgend wird die Baum-Ansicht des Dokuments angezeigt."
>>>>> > Which information should how be included?
>>>>> > Thank you in advance.
>>>>> > Yours,
>>>>> > Mag. Ferri Leberl

-- 
Brian D. Ripley,                  ripley_at_stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________ R-help_at_r-project.org mailing list https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code.

Received on Thu 24 Jan 2008 - 17:14:55 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 25 Jan 2008 - 10:30:08 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive