Re: [R] Tinn-R not working well with latest R

From: John C Frain <frainj_at_gmail.com>
Date: Mon, 11 Feb 2008 19:23:55 +0000

Pending the solution of the problem I use tinn-R as follows.

  1. I make none of the recommended additions to the Rprofile.site file
  2. I start tinn-R from the desktop and then load an r-file from my working directory.
  3. I then start R from the R| start preferred Rgui | menu in Tinn-R. This has the effect of starting R in the work directory and any saved data there will be loaded automatically.

I may be missing some functionality but I like the way it works. As far as I can see this is not documented.

I do occasionally have a problem which i can not replicate at will but which occurs occasionally. If I have the cursor in the middle of a line containing an R command any attempt to insert some thing i=at the cursor is inserted one character per line above the line that I am amending. For example If I try to change

x -> a + b + c+ d + e to
x -> a + b123 + c + d + e

Tinn-R displays

1
2
3
x -> a + b + c + d + e

with the cursor staying after the b

To recover close Tinn-R and restart and the problem vanishes. Any suggestions

Best Regards

John

On 11/02/2008, Farrel Buchinsky <fjbuch_at_gmail.com> wrote:
> I recently installed R 2.6.2 and am getting errors on startup that relate to
> svIDE being loaded by Tinn-R.
>
>
> Loading required package: tcltk
> Loading Tcl/Tk interface ... done
> Warning messages:
> 1: '\A' is an unrecognized escape in a character string
> 2: unrecognized escape removed from ";for Options\AutoIndent: 0=Off,
> 1=follow language scoping and 2=copy from previous line\n"
> 3: In grep(paste("[{]TclEval ", topic, "[}]", sep = ""), tclvalue(.Tcl("dde
> services TclEval {}")), :
> argument 'useBytes = TRUE' will be ignored
> Loading required package: svMisc
> Loading required package: R2HTML
>
>
> Any idea what is going on.
> I use R 2.6.2 on windows xp
>
> I also started R without the profile that Tinn-R made.
> If I manualy enter library(svIDE) then I get.
> > library(svIDE)
> Warning messages:
> 1: '\A' is an unrecognized escape in a character string
> 2: unrecognized escape removed from ";for Options\AutoIndent: 0=Off,
> 1=follow language scoping and 2=copy from previous line\n"
>
> So the underlying problem may be svIDE
> see: http://tolstoy.newcastle.edu.au/R/e2/help/07/04/15738.html
>
> Apparently, because of this error, several great features in Tinn-R are not
> working properly.
> Any solutions or workarounds?
>
>
> --
> Farrel
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> R-help_at_r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>

-- 
John C Frain
Trinity College Dublin
Dublin 2
Ireland
www.tcd.ie/Economics/staff/frainj/home.html
mailto:frainj_at_tcd.ie
mailto:frainj_at_gmail.com

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Mon 11 Feb 2008 - 19:34:44 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 11 Feb 2008 - 20:30:13 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive