Re: [R] rgl build warnings and loading error on Linux

From: Liviu Andronic <landronimirc_at_gmail.com>
Date: Tue, 18 Mar 2008 12:39:08 +0100

On Mon, Mar 17, 2008 at 11:07 PM, Liviu Andronic <landronimirc_at_gmail.com> wrote:
> This is what I have on my system:
> localhost liviu # locate libGL.so
> /usr/lib/opengl/xorg-x11/lib/libGL.so.1
> /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2
> /usr/lib/opengl/xorg-x11/lib/libGL.so
> /usr/lib/libGL.so
>
> However, the funny thing is that "/usr/lib/libGL.so" belongs to no
> package, while the other libGL.so belongs to media-libs/mesa.

I moved "/usr/lib/libGL.so" to "/usr/lib/libGL.so.bak" (it seemed like a broken soft link) and recreated a "/usr/lib/libGL.so" that linked to "/usr/lib/opengl/xorg-x11/lib/libGL.so.1.2". liviu_at_localhost ~ $ ls -l /usr/lib/libGL.so lrwxrwxrwx 1 root root 32 2008-03-18 12:16 /usr/lib/libGL.so -> opengl/xorg-x11/lib/libGL.so.1.2

However, the problem was not solved. A rebuilt rgl generates the same error on library load:
> dyn.load("/usr/lib/R/library/rgl/libs/rgl.so")
Error in dyn.load("/usr/lib/R/library/rgl/libs/rgl.so") :   unable to load shared library '/usr/lib/R/library/rgl/libs/rgl.so':   /usr/lib/R/library/rgl/libs/rgl.so: undefined symbol: glTexCoordPointer

Is there anything else that I could try?



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue 18 Mar 2008 - 11:42:28 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 18 Mar 2008 - 18:30:23 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive