Re: [R] start() in zoo

From: Gabor Grothendieck <ggrothendieck_at_gmail.com>
Date: Tue, 27 May 2008 18:20:00 -0400

My best guess at your data based on what you posted works fine:

> d <- zoo(c(NA, 8.792, 8.725))
> start(d)

[1] 1
> packageDescription("zoo")$Version

[1] "1.5-3"
> R.version.string # Vista
[1] "R version 2.7.0 Patched (2008-05-11 r45672)"

Try sending me the output of dput(d) along with the version info so the problem can be recreated.

On Tue, May 27, 2008 at 5:56 PM, Arshavir <grigorian_at_gmail.com> wrote:
> Hi,
>
> I'm trying to get the beginning of my zoo object's index through start(d)
> but sometimes get an error:
>
> Error in start(d):
> Unused argument (s) (c(NA, 8.792, 8.725, ...)
>
> The data(d) is retrieved from Bloomberg through RBloomberg. I am pulling 6
> tickers (which means I'm getting 6 columns), and not all of them have data
> going back to my start date. When I print the object, there are no errors.
> And I do see the NA for some of the columns for the earlier dates. Also,
> this is daily data.
>
> Any suggestions on what could be causing this and also what the error means
> would be greatly appreciated.



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Wed 28 May 2008 - 00:50:21 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 28 May 2008 - 01:30:43 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive