Re: [R] Troubles plotting lrm output in Design Library

From: Frank E Harrell Jr <f.harrell_at_vanderbilt.edu>
Date: Fri, 30 May 2008 11:54:14 -0500

Patrizio Frederic wrote:
> 2008/5/29 Frank E Harrell Jr <f.harrell@vanderbilt.edu>:

>> Patrizio Frederic wrote:
>>> dear Harrell,
>>> thank you for quick reply and suggestions. I still have the problem:
>>>
>>> library(Design)
>>> x   = rnorm(100)
>>> y   = runif(100)<(exp(x)/(1+exp(x)))
>>> y   = 0*y+1*y
>>> d   = datadist(x,y)
>>> options(datadist="d")
>>> fit = lrm(y~x)
>>> # works fine, but
>>> plot(fit) #produce the error message
>> I cannot reproduce the error on Linux R 2.7.0 using the same version of the
>> packages you are using.
>>
>> Frank
>>

>

> just for the records, I solved the problem: in Windows R 2.7.0 one has to set:
>
> d = datadist(x,y)
> .Options$datadist="d"
>
> done that functions summary.Design, and plot.Design work fine.
>
> PF
>

Thanks for the solution. But I wish someone would tell us why the solution makes sense. If you have changed your R environment in any way from the defaults please let us know.

Frank

-- 
Frank E Harrell Jr   Professor and Chair           School of Medicine
                      Department of Biostatistics   Vanderbilt University

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Mon 02 Jun 2008 - 03:25:03 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 02 Jun 2008 - 04:30:35 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive