[R] Fwd: Problemas usando jri0.4-1 y R 2.7.0

From: Borja Soto Varela <borja.soto_at_gmail.com>
Date: Mon, 02 Jun 2008 17:56:43 +0200

Hello, this is the first time I send a mail to r-help mailing list.

Mi problema es el siguiente: I'm developing a program in java with calls in R and I can`t use jri 0.4-1 with R 2.7 or 2.6 .but it runs with 2.4.

The problem that I get when using the latest version of R is as follows:

Cannot find JRI native library!
Please make sure that the JRI native library is in a directory listed in java.library.path.

> java.lang.UnsatisfiedLinkError: C:\JRI_0.4-1\JRI\jri.dll: No se encontró > el proceso especificado
> at java.lang.ClassLoader$NativeLibrary.load(Native Method)
> at java.lang.ClassLoader.loadLibrary0(Unknown Source)
> at java.lang.ClassLoader.loadLibrary(Unknown Source)
> at java.lang.Runtime.loadLibrary0(Unknown Source)
> at java.lang.System.loadLibrary(Unknown Source)
> at org.rosuda.JRI.Rengine.<clinit>(Rengine.java:9)
> at vista.main.Main.main(Main.java:12)

C:\JRI_0.4-1\JRI\j is included in the system path (in fact, the program runs fine with R 2.4.0). I wonder if someone also has this problem and how it can solve.

Any suggestions are highly appreciated,
Thanks,
Borja

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Mon 02 Jun 2008 - 17:46:56 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 02 Jun 2008 - 18:30:40 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive