Re: [R] Problem in executing R on server

From: Rolf Turner <r.turner_at_auckland.ac.nz>
Date: Fri, 06 Jun 2008 13:58:19 +1200

On 6/06/2008, at 1:36 PM, Jason Lee wrote:

> Hi R-listers,
>
> I have problem in executing my R on server. It returns me
>
> Error: cannot allocate vector of size 15.8 Mb
>
> each time when i execute R on the server. But it doesnt give me any
> problem
> when i try executing on my own Pc (except it runs extremely slow).
>
> Any pointers to this? I tried to read the FAQ on this issue before
> in the
> archive but it seems there is no one solution to this. I tried to
> simplified my code but it seems the problem is still the same.

Might it be the case that there is a .RData on the server which contains a god-awful huge object?

You could try R --vanilla (I think that's the right flag!) or move .RData to (say) save.RData before trying to start R, and see what happens.

        cheers,

                Rolf Turner

######################################################################
Attention:\ This e-mail message is privileged and confid...{{dropped:9}}

R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Fri 06 Jun 2008 - 03:07:53 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 06 Jun 2008 - 04:30:41 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive