[R] Problem with densityplot from the lattice package

From: Malte Brockmann <malte.brockmann_at_ebs.edu>
Date: Wed, 11 Jun 2008 16:12:36 +0200 (CEST)

Dear list,

I just experienced some strange behavior of the densityplots provided by the lattice package. Depending on the values for "from" and "to" that are passed on to the function for kernel density estimates, the densityplot excludes the jittered stripplot that is routinely included in lattice densityplot.

Example:

library(lattice)

test<-runif(100)
densityplot(test) #the standard density plot without problems
densityplot(test, from=0, to=1) #stripplot is excluded 
densityplot(test, from=-1, to=2) #stripplot is again included

Any hints how I could get the stripplot back in the second example?

Tanks in advance
Malte

> sessionInfo()

R version 2.7.0 (2008-04-22)
i386-pc-mingw32

locale:
LC_COLLATE=German_Germany.1252;LC_CTYPE=German_Germany.1252;LC_MONETARY=German_Germany.1252;LC_NUMERIC=C;LC_TIME=German_Germany.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] lattice_0.17-8

loaded via a namespace (and not attached): [1] grid_2.7.0



sent via xelos.net | the communication and groupware solution

R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Wed 11 Jun 2008 - 16:00:11 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 11 Jun 2008 - 16:30:41 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive