[R] Different Autocorrelation using R and other softwares

From: Yinny <wwan3887_at_mail.usyd.edu.au>
Date: Sun, 06 Jul 2008 15:22:35 +1000


Dear All,

  Would like to ask the inconsistency in the autocorrelation from R with SPSS/Minitab. I have tried a dataset x with 20 data (1-20) and ask R to give the autocorrelation of different lags using the command < acf(x, lag.max=100, type = "correlation"), However while SPSS and Minitab give the same answers (0.85 for lag1), R gives 0.3688 which is much smaller.

  Obviously, the answers from SPSS/Minitab are correct by verifying in Excel. Is R using another definition in calculating the traditional autocorrelation for a time-series?

  Thanks for your attention. Would be very grateful if anyone can help.

Yinny
School of Mathematics & Statistics
University of Sydney

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Sun 06 Jul 2008 - 06:34:37 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sun 06 Jul 2008 - 09:31:05 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive