[R] problem with save function

From: Juan Manuel Barreneche <jumanbar_at_gmail.com>
Date: Mon, 18 Aug 2008 20:51:20 -0300


Hello list! i write because i'm having a strange problem with the "save" function, here an example:

> x <- stats::runif(20)
> y <- list(a = 1, b = TRUE, c = "oops")
> save(x, y, file = "xy.Rdata")
> xy <- load("xy.Rdata")
> xy

[1] "x" "y"

why does this happens, when:
> x

 [1] 0.96586833 0.60340508 0.23465887 0.01415043 0.57691296 0.13302310
 [7] 0.01874176 0.59097297 0.41550847 0.76732502 0.01802066 0.11413294

[13] 0.93441672 0.70013043 0.10277732 0.43738180 0.96744498 0.45388743
[19] 0.84598918 0.96785481

> y
$a
[1] 1

$b
[1] TRUE
$c
[1] "oops"

I run R in openSUSE 10.2, in KDE with Konsole, my version and OS information is:
> R.Version()
$platform
[1] "i686-pc-linux-gnu"

$arch
[1] "i686"

$os
[1] "linux-gnu"
$system
[1] "i686, linux-gnu"

$status
[1] ""

$major
[1] "2"

$minor
[1] "7.0"

$year
[1] "2008"

$month
[1] "04"

$day
[1] "22"

$`svn rev`
[1] "45424"

$language
[1] "R"

$version.string
[1] "R version 2.7.0 (2008-04-22)"

many thanks in advance,

Juan

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Mon 18 Aug 2008 - 23:53:37 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 19 Aug 2008 - 00:33:55 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive