[R] Problem with Rmpi and snow - makeCluster(type="MPI") not working

From: Rainer M Krug <r.m.krug_at_gmail.com>
Date: Mon, 24 Nov 2008 16:45:04 +0200


Hi

I managed tio install Rmpi and to load it, but I get the following errormessage when I try to create an MPI cluster and R hangs (no response):

library(Rmpi)
[head001:15781] mca: base: component_find: unable to open osc pt2pt: file not found (ignored)
> library(snow)
> cl <- makeCluster(2, type = "MPI")
Rscript execution error: No such file or directory Rscript execution error: No such file or directory

I am using the following version:

> version

               _
platform       x86_64-unknown-linux-gnu
arch           x86_64
os             linux-gnu
system         x86_64, linux-gnu
status
major          2
minor          7.2
year           2008
month          08
day            25
svn rev        46428
language       R

version.string R version 2.7.2 (2008-08-25)
>

Any help welcome,

Rainer

-- 
Rainer M. Krug, PhD (Conservation Ecology, SUN), MSc (Conservation
Biology, UCT), Dipl. Phys. (Germany)

Centre of Excellence for Invasion Biology
Faculty of Science
Natural Sciences Building
Private Bag X1
University of Stellenbosch
Matieland 7602
South Africa

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Mon 24 Nov 2008 - 14:48:44 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 24 Nov 2008 - 15:30:27 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive