Re: [R] Error in sqlCopy in RODBC

From: Dieter Menne <dieter.menne_at_menne-biomed.de>
Date: Wed, 26 Nov 2008 01:04:33 -0800 (PST)

BKMooney wrote:
>
> I am trying to copy portions of tables from one SQL database to another,
> using sqlCopy in the RODBC package.
>
> ...
> I am currently getting an error:
> Error in sqlSave(destchannel, dataset, destination, verbose = verbose, :
> table 'LocalTable' already exists
>

I can reproduce your error with my example file and fast=TRUE. You might try fast=FALSE
and append=TRUE when things like this happens. The following works for me

library(RODBC)
channel = odbcConnectAccess("db.mdb")
sqlCopy(channel,"Select * from tab","newtab",destchannel=channel,   safer=TRUE,append=TRUE,rownames=FALSE,fast=FALSE) odbcClose(channel)

-- 
View this message in context: http://www.nabble.com/Error-in-sqlCopy-in-RODBC-tp20691929p20697101.html
Sent from the R help mailing list archive at Nabble.com.

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Wed 26 Nov 2008 - 09:12:22 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 26 Nov 2008 - 19:30:28 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive