Re: [Rd] R GUI editor window - help field does not return the help topic (PR#14146)

From: <simon.urbanek_at_r-project.org>
Date: Wed, 16 Dec 2009 17:05:23 +0100 (CET)


Yan,

On Dec 16, 2009, at 10:13 AM, Yan ALPEROVYCH wrote:

> Hello Simon,=20
>=20
> I did read the posting guide, and I did as your colleague from the GUI =
discussion instructed me to (Forwarded text bellow). It's ok, I got my = lesson.=20
>=20
> The session info:
>=20
>> sessionInfo()
> R version 2.10.1 (2009-12-14)=20
> x86_64-apple-darwin9.8.0=20
>=20
> locale:
> [1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8
>=20
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base   =
 =20
>>=20
>=20
> The problem can be reproduced as:
> 1. Click on the "New document" in the R console.=20
> 2. In the popped editor window, type any command, e.g. "cbind", in the =
help field in the upper right corner.
>=20
> Normally, it should show you the content of the help topic. In my case = it shows me only a blank box.
>=20

Great, thanks - I can reproduce it now. Fixed in r5539 (you can try = tonight's build tomorrow).

Thanks,
Simon

> On Dec 16, 2009, at 3:39 PM, Simon Urbanek wrote:
>=20
>> Please read the posting guide before submitting bug reports, =
especially if you don't even know that it's the proper way! >>=20
>> I cannot reproduce the problem, so please supply the details as we = kindly ask you to - at the very least sessionInfo()... Also the proper = place for Mac-related questions is R-SIG-Mac (see "About R" in the GUI).
>>=20
>> Thanks,
>> Simon
>>=20
>>=20
>>=20
>> On Dec 15, 2009, at 1:40 PM, y_alperovych_at_yahoo.fr wrote:
>>=20

>>> Full_Name: Yan Alperovych
>>> Version: R 2.10.1, GUI 1.31
>>> OS: Mac OS 10.6.2
>>> Submission from: (NULL) (139.165.27.244)
>>>=20
>>>=20

>>> Hello everyone,=20

>>>=20
>>> I am not sure if I am at the right place to put this question, so =
don't hesitate
>>> to redirect me to the correct mailing list. My question is about the =
editor
>>> window under the R GUI on Mac OS 10.6.2. Before the upgrade to R =
2.10.1 with GUI
>>> 1.31, I was able to call for the help topics from the spotlight-like =
help field
>>> in the upper right corner of the editor window. Now it only returns =
me a blank
>>> box, which still slides as before, but the help content is missing. =
Is this a
>>> frequent problem or is it related to my specific computer? And if =
it's a general
>>> issue, is there some solution please?
>>>=20
>>> Thank you for the replies or possible indications on where can I =
find more
>>> hints.
>>>=20

>>> Yan ALPEROVYCH
>>> Financial Management, FRFC-FNRS Fellow
>>> HEC-ULg Management School
>>> Tel.: +32(4)/232.74.30
>>> GSM: +32(4)/85.75.04.16=20
>>> E-mail: y.alperovych_at_ulg.ac.be
>>>=20

>>> ______________________________________________
>>> R-devel_at_r-project.org mailing list
>>> https://stat.ethz.ch/mailman/listinfo/r-devel
>>>=20
>>>=20
>>=20
>=20
>=20
>=20
>=20
>> From: Philippe Grosjean <phgrosjean_at_sciviews.org>
>> Date: December 15, 2009 7:29:01 PM GMT+01:00
>> To: Yan ALPEROVYCH <y.alperovych_at_ulg.ac.be>
>> Cc: r-sig-gui_at_stat.math.ethz.ch
>> Subject: Re: [R-gui] R GUI editor window - help field does not return =
the help	topic.
>>=20
>> You should fill a bug report for R.
>>=20
>> PhG
>> ..............................................<=B0}))><........
>> ) ) ) ) )
>> ( ( ( ( (    Prof. Philippe Grosjean
>> ) ) ) ) )
>> ( ( ( ( (    Numerical Ecology of Aquatic Systems
>> ) ) ) ) )   Mons University, Belgium
>> ( ( ( ( (
>> ..............................................................
>>=20

>> Yan ALPEROVYCH wrote:
>>> Hello everyone, I am not sure if I am at the right place to put this =
question, so don't hesitate to redirect me to the correct mailing list. =
My question is about the editor window under the R GUI on Mac OS 10.6.2. =
Before the upgrade to R 2.10.1 with GUI 1.31, I was able to call for the =
help topics from the spotlight-like help field in the upper right corner =
of the editor. Now it only returns me a blank box, which still slides as =
before, but the help topic is missing. Is this a frequent problem or is = it related to my specific computer? And if it's a general issue, is = there some solution please?
>>> Thank you for the replies or possible indications on where can I =
find more hints.
>>> Yan ALPEROVYCH
>>> Financial Management, FRFC-FNRS Fellow
>>> HEC-ULg Management School
>>> Tel.: +32(4)/232.74.30
>>> GSM: +32(4)/85.75.04.16 E-mail: y.alperovych_at_ulg.ac.be
>>> _______________________________________________
>>> R-SIG-GUI mailing list
>>> R-SIG-GUI_at_stat.math.ethz.ch
>>> https://stat.ethz.ch/mailman/listinfo/r-sig-gui
>=20
>=20

R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 16 Dec 2009 - 16:31:35 GMT

This archive was generated by hypermail 2.2.0 : Mon 28 Dec 2009 - 23:11:15 GMT