Re: [R] Help! R won't start

About this list Date view Thread view Subject view Author view Attachment view

From: Andrew Perrin (clists@perrin.socsci.unc.edu)
Date: Wed 28 May 2003 - 00:23:41 EST


Message-id: <Pine.LNX.4.53.0305271021340.26135@perrin.socsci.unc.edu>

On Tue, 27 May 2003, Prof Brian Ripley wrote:

> try R --vanilla
>
> The likely story is that you have library(MASS) in the .Rprofile being
> found. That does not work in 1.7.0 (and is not the recommended way to do
> this: see the help archives for solutions, one of which is to run
> update.packages() and get the current VR bundle).
>

Thanks for all the quick responses! However, I don't have library(MASS)
anywhere as far as I can tell - just the stock
/usr/lib/R/library/base/R/Rprofile which contains no such call.

Starting R from a different directory works fine. Furthermore, starting R
with --no-restore-data works fine, and I can then restore the data
manually using load(".RData"). That might provide a clue.

The data file is extremely large:

aperrin@perrin:~/afshome/papers/microcultures/R$ ls -l .RData
-rw-r--r-- 1 aperrin aperrin 104355299 May 27 10:20 .RData

which could be the problem too.

ap

----------------------------------------------------------------------
Andrew J Perrin - http://www.unc.edu/~aperrin
Assistant Professor of Sociology, U of North Carolina, Chapel Hill
clists@perrin.socsci.unc.edu * andrew_perrin (at) unc.edu

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Tue 01 Jul 2003 - 09:11:51 EST