RE: [R] Problems in plot

About this list Date view Thread view Subject view Author view Attachment view

From: Prof Brian Ripley (ripley@stats.ox.ac.uk)
Date: Wed 05 May 2004 - 01:49:55 EST


Message-id: <Pine.LNX.4.44.0405041646110.16915-100000@gannet.stats>

You have been asked for a reproducible set of conditions -- this is the
first time `minimized' has been mentioned. If you can find a completely
reproducible set of actions please file a bug report (after reading the
FAQ section carefully).

We cannot help you otherwise, and don't want to spend time guessing what
you might have forgotten to tell us. (I see you have not told us if you
use MDI or SDI mode, for example.)

On Tue, 4 May 2004, Yao, Minghua wrote:

> It seems to me that the problem happens to the graphic window that is
> generated immediately after the R window is minimized.
>
> Minghua
>
> ________________________________
>
> From: r-help-bounces@stat.math.ethz.ch on behalf of Yao, Minghua
> Sent: Fri 4/30/2004 4:12 PM
> To: Prof Brian Ripley
> Cc: R Help
> Subject: RE: [R] Problems in plot
>
>
>
> The problem is still there if windows() is used.
>
> Minghua
>
> ________________________________
>
> From: Prof Brian Ripley [mailto:ripley@stats.ox.ac.uk]
> Sent: Thu 4/29/2004 9:31 AM
> To: Yao, Minghua
> Cc: R Help
> Subject: Re: [R] Problems in plot
>
>
>
> The primary graphics device under Windows is called *windows* not *x11*.
>
> Something in your Windows setup is sometimes failing to choose a
> reasonable window size. I have never seen that, and suspect it is nothing
> to do with it, but please use windows() and see if the problem vanishes.
>
> On Thu, 29 Apr 2004, Yao, Minghua wrote:
>
> > Hello,
> >
> >
> >
> > I have R1.9.0 under Windows XP. My program plots several plots using
> >
> > x11()
> > par(cex = 0.75)
> > ......
> > x11()
> > par(cex = 0.75)
> > ......
> > x11()
> > par(cex = 0.75)
> > ......
> > x11()
> > par(cex = 0.75)
> > ......
> >
> > Sometimes, one of them generates a small frame only with title area "R graphics: Device X (ACTIVE)". The message in the console window is
> >
> > Error in plot.new() : Figure margins too large
> >
> > This program ran well under R1.6.X under Windows NT.
> >
> > It seems to me that it is not a specific x11() that generates that small graphics frame.
> >
> > Thank you for you help in advance.
> >
> > Minghua

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________ R-help@stat.math.ethz.ch mailing list https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Mon 31 May 2004 - 23:05:07 EST