Re: [R] Problem with plot.

About this list Date view Thread view Subject view Author view Attachment view

From: Tamas Papp (tpapp@axelero.hu)
Date: Wed 12 May 2004 - 21:26:51 EST


Message-id: <20040512112651.GA957@localhost>

On Wed, May 12, 2004 at 12:19:41PM +0200, witek wrote:

> Hi!
> After loading some functions in R1.9.0 and some computations I am getting the following errors (see below with plot).
> I have now idea how to figure out whats wrong. Can anyone give me a hint where to start to debug?
>
> Eryk
>
> plot(1,1) fine.
>
> plot(hist(1:10,plot=F))
> Error in xy.coords(x, y, xlabel, ylabel, log) :
> x and y lengths differ

plot(hist(1:10,plot=F))

works fine on my system (as expected). plot calls the appropriate
method (plot.histogram) in this case to make a plot. You mentioned
"loading some functions", what functions where these?

Do you get the same error when you load nothing before these commands?
If so, then try to isolate the cause of the problem. See if hist()
and plot.histogram() are redefined anywhere.

Best,

Tamas

-- 
Tamás K. Papp
E-mail: tpapp@axelero.hu
Please try to send only (latin-2) plain text, not HTML or other garbage.

______________________________________________ R-help@stat.math.ethz.ch mailing list https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Mon 31 May 2004 - 23:05:09 EST