Re: [R] .First() in R 1.9.0

About this list Date view Thread view Subject view Author view Attachment view

From: Petr Pikal (petr.pikal@precheza.cz)
Date: Fri 21 May 2004 - 22:33:35 EST


Message-id: <40AE133F.20230.1C2D2E3@localhost>

Hi

I suppose it was answered in few weeks ago and you probably can
avoid it by setting

library(graphics)

before calling x11 and par in your .First fuction

The correct solution is probably with setHook function

?setHook

but I was not able to get it work in my .Rprofile, though I read the
help page and made some trial and errors.

Cheers
Petr

On 21 May 2004 at 12:18, Timur Elzhov wrote:

> Dear R experts,
>
> I just upgraded R from 1.8.1 to 1.9.0 version. My .First()
> function in ~/.Rprofile contains x11() and par() functions.
>
> .First <- function() {
> x11(display = "", 8.0, 5.0)
> par(las = 1, ...)
> ## ...
> }
>
> And, R claims now, on startup:
>
> [hello messages skiped ...]
> Error in .First() : couldn't find function "x11"
> >
>
> I commented "x11" string, and get the same error about par:
> Error in .First() : couldn't find function "par"
> >
>
> There was no such a problen with previos R version.
> Why .First function knows nothing about "x11" and "par" functions?
> Thanks.
>
> --
> WBR,
> Timur
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide!
> http://www.R-project.org/posting-guide.html

Petr Pikal
petr.pikal@precheza.cz

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Mon 31 May 2004 - 23:05:12 EST