Re: [R] R-1.9.0: Error in paste(ncomp, "LV's") : Argument "ncomp" is missing, with no default

About this list Date view Thread view Subject view Author view Attachment view

From: Uwe Ligges (ligges@statistik.uni-dortmund.de)
Date: Fri 28 May 2004 - 04:31:21 EST


Message-id: <40B633F9.5080508@statistik.uni-dortmund.de>

ryszard.czerminski@pharma.novartis.com wrote:
> Is it just my installation or bug in 1.9.0 ?
> The same thing works fine in 1.8.1
>
> Best regards,
>
> Ryszard
>
> # R-1.9.0
> library(pls.pcr)
> nr <- 8; ndim <- 2
> x <- matrix(rnorm(nr*ndim), nrow=nr)
> y <- as.matrix(x[,1])
> for (i in 2:ndim) y <- y + x[,i]
> y <- y + rnorm(length(y))
> m <- pls(x,y,validation='CV')
> # Error in paste(ncomp, "LV's") : Argument "ncomp" is missing, with no
> default
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html

That's a bug in the recent version of the package "pls.pcr" (and not
related to the R version). Please report it to the package maintainer.

Uwe Ligges

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Mon 31 May 2004 - 23:05:13 EST