[R] no transparent background in bmp

About this list Date view Thread view Subject view Author view Attachment view

From: Jeff D. Hamann (jeff.hamann@forestinformatics.com)
Date: Fri 28 May 2004 - 08:24:40 EST


Message-id: <3163.67.171.204.151.1085696680.squirrel@www.forestinformatics.com>

I've been attempting to export a graphics file of my lattice plots and no
matter what color I use for the bg= argument in the bmp/jpeg/png function,
the background is grey.

bmp(filename = "c:/my_paper/resids.bmp", width=1024, height=1024,
pointsize=10, bg="transparent")

# these are lattice plots. plot them in a 3x2 matrix
print( hgqqplot, position=c(0.0, 0.66, 0.5, 1.0 ), more=TRUE )
print( hgplot, position=c(0.5, 0.66, 1.0, 1.0 ), more=TRUE )
print( dgqqplot, position=c(0.0, 0.33, 0.5, 0.66 ), more=TRUE )
print( dgplot, position=c(0.5, 0.33, 1.0, 0.66 ), more=TRUE )
print( cwgqqplot, position=c(0.0, 0.0, 0.5, 0.33 ), more=TRUE )
print( cwgplot, position=c(0.5, 0.0, 1.0, 0.33 ), more=FALSE )

dev.off()

I've tried white, no argument at all, transparent, etc. and all yield the
same results. Is this broken, or am I not using the function correctly.

Thanks,
Jeff.

-- 
Jeff D. Hamann
Forest Informatics, Inc.
PO Box 1421
Corvallis, Oregon 97339-1421
phone 541-754-1428
jeff.hamann@forestinformatics.com
http://www.forestinformatics.com

______________________________________________ R-help@stat.math.ethz.ch mailing list https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Mon 31 May 2004 - 23:05:13 EST