[R] Seg. faults in mapthin

From: Kevin Bartz <kbartz_at_loyaltymatrix.com>
Date: Fri 02 Jul 2004 - 02:50:15 EST


Hi everyone! I know segmentation faults are awfully hard to diagnose, but I'm experiencing a fairly regular pattern of seg. faults when plotting using map in the maps package. Starting R fresh, I run:

require(maps)
for (i in 1:50) {
  cat(i, "\n")
  map("state")
}

I always get the same result:

1
2
3
4
5

Process R segmentation fault at Thu Jul 1 09:07:39 2004

With some browsering, I've zeroed in on the source of the segmentation fault: map's call to mapthin. Funny thing is, when I comment out the call to mapthin, everything works consistently, without a hitch, and with no apparent difference in the map.

Still, I'd rather work with the package the way it was built. I must be losing something by cutting out the call to mapthin.

I was wondering if anyone has any ideas. I've never had a segmentation fault before on this particular machine, but these few lines always produce the same unfortunate result. Has anyone else experienced segmentation faults plotting using map in the maps package? Is there any way I might rectify it? I'm on SuSE Linux, by the way, with:

> version

         _
platform x86_64-unknown-linux-gnu

arch     x86_64                  
os       linux-gnu               
system   x86_64, linux-gnu       
status   alpha                   
major    1                       
minor    9.1                     
year     2004                    
month    06                      
day      13                      
language R                       

Thanks for any help you can provide,

Kevin



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri Jul 02 02:58:35 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 08:59:00 EST