[R] Embarrassingly naive question regarding graphics on Mac OS X

From: Matthew Cohen <owl_of_minerva_at_hotmail.com>
Date: Sun 04 Jul 2004 - 10:51:41 EST


I am having trouble saving graphs. Using the Aqua interface (which is not my preferred interface), I have no problems plotting a graph, adding additional lines, points, references, etc., and then saving it to a file using, for example, the dev2bitmap command. I have found that, running R with Xemacs+ESS under X11 (which I prefer over Aqua), this is not possible. I can either send the graph to a Quartz or X11 window, where I can then manipulate it using my mouse, but not save it (using dev2bitmap or postscript or any other saving command creates a 4kb file that is entirely blank when loaded using another viewing program); or I can save it, but without the opportunity of manipulating it first.

I'm guessing that when I run R through X11/Xemacs/ESS, that it doesn't have access to the postscript converter that it uses when I run it through the Aqua interface. But this is just a guess, and regardless of whether it is correct, I have no idea how to fix the problem. Any suggestions would be enormously appreciated.

I am running R 1.9.1 on Mac OS 10.3.4 with Xemacs 21.4-15 and ESS 5.2.0. I've installed Xemacs using Fink 0.7.0, manually installed ESS according to the directions included in its readme file, and compiled R from source, placing the R.Framework in my /sw directory.

Matt



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Jul 04 10:57:16 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 09:27:50 EST