Re: [R] RCMD fails in Windows XP

From: Duncan Murdoch <dmurdoch_at_pair.com>
Date: Wed 14 Jul 2004 - 11:08:20 EST

On Wed, 14 Jul 2004 10:12:45 +1000, <Gavin.Kennedy@csiro.au> wrote:

>I have setup R 1.9.1 on my Dell laptop running windows XP. I have
>installed it to C:\R\rw1091. Rgui runs fine, but Rcmd fails if run with
>parameters (i.e. install). The windows dialog box cheerfully says "R for
>Windows front-end has encountered a problem and needs to close. We are
>sorry for the inconvenience." Running the visual C++ debugger informs me
>that there is an unhandled exception in rcmd.exe. I have seen similar
>problems in R-help and have tried to follow the advice given, but the
>earlier problems occurred for Rgui.exe and were overcome by setting the
>HOMEPATH variable. I have tried this and set every variable possible to
>ensure no blank spaces appear in any of the paths. But still I get this
>error. Any further suggestions would be appreciated.

You don't mention your setup. Have you followed the instructions in readme.packages? Rcmd INSTALL sets up environment variables, then runs Perl. I think it's pretty much equivalent to doing the sequence below in a command shell. Can you try those commands, and see if you get an error?

set R_HOME=C:/R/rw1091
set R_VERSION=1.9.1
set R_CMD=R CMD
set R_OSTYPE=windows

set PATH=C:\R\rw1091\bin;your old path
set TMPDIR=c:/TEMP (unless you already had TMPDIR set) set PERL5LIB=C:\R\rw1091\share\perl;<old PERL5LIB value, if you had one>
set TEXINPUTS=C:\R\rw1091\share\texmf;<old TEXINPUTS, if you had one>

perl C:\R\rw1091/bin/INSTALL <other command line args>

I think I got all the \ and / right, but I'm not certain.

Duncan Murdoch



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Jul 14 11:20:52 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:54:56 EST