[R] Install R on AIX 5.2 64 Bit

From: Liao, Kexiao <liao1k_at_cmich.edu>
Date: Sat 17 Jul 2004 - 04:47:10 EST


Hi your guys,

    Recently, I installed R-1.9.1 on AIX 5.2 with 64 bits environment; I already have following software installed on AIX before I compile R-1.9.1 source codes:  

g++ 2.9.aix51.020209-4 The GNU C++ compiler and headers

gcc 2.9.aix51.020209-4 The GNU gcc C compiler and headers

xlf XL Fortran for AIX

perl 5.6.1-2

zlib 1.1.3-10  

   For latex and makeinfo stuffs, I have not found from my AIX 5.2 P690 system.  

 After I run the following command:

configure

make  

Following executable binaries codes have been generated in RHOME/bin directory:  

bash-2.05b$ ls -al

total 15900

drwx------ 2 liao1k staff 512 Jul 09 11:27 .

drwx------ 13 liao1k staff 1024 Jul 09 11:25 ..

-rwxr-xr-x 1 liao1k staff 1680 Jul 09 11:24 BATCH

-rwxr-xr-x 1 liao1k staff 1738 Jul 09 11:24 COMPILE

-rwxr-xr-x 1 liao1k staff 24130 Jul 09 11:24 INSTALL

-rwxr-xr-x 1 liao1k staff 1635 Jul 09 11:24 LINK

-rwxr-xr-x 1 liao1k staff 6314 Jul 09 11:24 R

-rwx------ 1 liao1k staff 7736209 Jul 09 11:27 R.bin

-rwxr-xr-x 1 liao1k staff 2377 Jul 09 11:24 REMOVE

-rwxr-xr-x 1 liao1k staff 909 Jul 09 11:24 Rcmd

-rwxr-xr-x 1 liao1k staff 8662 Jul 09 11:24 Rd2dvi

-rwxr-xr-x 1 liao1k staff 838 Jul 09 11:24 Rd2txt

-rwxr-xr-x 1 liao1k staff 3240 Jul 09 11:24 Rdconv

-rwxr-xr-x 1 liao1k staff 837 Jul 09 11:24 Rdiff

-rwxr-xr-x 1 liao1k staff 2997 Jul 09 11:24 Rprof

-rwxr-xr-x 1 liao1k staff 2594 Jul 09 11:24 SHLIB

-rwxr-xr-x 1 liao1k staff 16220 Jul 09 11:24 Sd2Rd

-rwxr-xr-x 1 liao1k staff 15245 Jul 09 11:24 build

-rwxr-xr-x 1 liao1k staff 56547 Jul 09 11:24 check

-rwxr-xr-x 1 liao1k staff 6304 Jul 09 11:24 config

-rwxr-xr-x 1 liao1k staff 3474 Jul 09 11:24 f77

-rwxr-xr-x 1 liao1k staff 210608 Jul 09 11:24 libtool

-rwxr-xr-x 1 liao1k staff 2929 Jul 09 11:24 mkinstalldirs

-rwxr-xr-x 1 liao1k staff 413 Jul 09 11:24 pager

-rwxr-xr-x 1 liao1k staff 24442 Jul 09 11:24 texi2dvi

bash-2.05b$ pwd

/home/liao1k/r-1.9.1/R-1.9.1/bin

bash-2.05b$    

However if I run R command, I got following error message:  

bash-2.05b$ ./R

Fatal error: unable to open the base package  

bash-2.05b$  

  Can any one give me some advice? Thanks in advance!  

Kexiao    

        [[alternative HTML version deleted]]



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Jul 17 04:55:34 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 02:36:40 EST