[R] gray background in png

From: Sundar Dorai-Raj <sundar.dorai-raj_at_pdf.com>
Date: Sun 18 Jul 2004 - 12:13:53 EST


Hi all,

   I'm having a problem creating png images with trellis.device. I would like to create many plots with a white background using a sequence number in the file argument (i.e. "%02d"). The first plot is as expected with a white background. However, the second and all subsequent plots have a gray background. I would like all plots to have a white (or transparent) background. Below is an example:

library(lattice)
z <- expand.grid(A = LETTERS[1:8], B = letters[1:6]) z$x <- z$y <- rep(1, nrow(z))
trellis.device(png, file = "test%02d.png", bg = "white") lset(col.whitebg())
xyplot(y ~ x | A * B, data = z, layout = c(4, 6)) dev.off()

This is also the case for jpeg and bmp though win.metafile and postscript do not have this problem. Is this a bug or am I missing something obvious?

I found one reference that implies this may be expected behaviour but I'm not sure if I interpretted the comment correctly.

http://finzi.psych.upenn.edu/R/Rhelp02a/archive/18890.html

> R.version

          _
platform i386-pc-mingw32

arch     i386
os       mingw32

system i386, mingw32
status
major 1
minor 9.1
year 2004
month 06
day 21
language R
> help(package = lattice)

                Information on Package 'lattice'

Description:

Package: lattice
Version: 0.9-12
Date: 2004/06/01
<snip>



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sun Jul 18 12:22:01 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 02:36:41 EST