RE: [R] R 1.9.1 compilation error (on AIX 5.1)

From: Liaw, Andy <andy_liaw_at_merck.com>
Date: Tue 20 Jul 2004 - 04:09:40 EST


xlc/xlf are IBM compilers. I don't know if they are bundled with the OS. GCC is free, but not necessarily found on all AIX systems (unless IBM decided to bundle GCC with AIX, which would seem odd to me...).

Can't really help you here: The GCC on our AIX is too outdated to try.

Andy

> From: Liao, Kexiao
>
> Dear R Development Team,
> I have IBM AIX 5.2 and am trying to install R-1.9.1 on it. If I use
> the CC=xlc as the C compiler command, I got the following
> error message.
>
> configure:3641: checking for gcc
> configure:3667: result: xlc
> configure:3911: checking for C compiler version
> configure:3914: xlc --version </dev/null >&5
> ./configure[3915]: xlc: not found
> configure:3917: $? = 127
> configure:3919: xlc -v </dev/null >&5
> ./configure[3920]: xlc: not found
> configure:3922: $? = 127
> configure:3924: xlc -V </dev/null >&5
> ./configure[3925]: xlc: not found
> configure:3927: $? = 127
> configure:3950: checking for C compiler default output file name
> configure:3953: xlc -O -qmaxmem=-1 -qarch=auto -qtune=auto -q64
> -I/usr/local/inc
> lude -L/usr/local/lib conftest.c >&5
>
> It seems AIX does not have xlc, gcc is the correct choice
> for most of
> the AIX system.
>
> Kexiao
>
>
>
> -----Original Message-----
> From: r-help-bounces@stat.math.ethz.ch
> [mailto:r-help-bounces@stat.math.ethz.ch] On Behalf Of Liaw, Andy
> Sent: Monday, July 19, 2004 8:26 AM
> To: 'Frankie Cheung'
> Cc: 'Prof Brian Ripley'; R-help@stat.math.ethz.ch
> Subject: RE: [R] R 1.9.1 compilation error (on AIX 5.1)
>
> The following are the entries in the config.site file I used
> to compile
> R-1.9.1 on AIX. See if that helps.
>
> CC=xlc
> CFLAGS="-O -qmaxmem=-1 -qarch=auto -qtune=auto -q64"
> F77=xlf
> FFLAGS="-O -qmaxmem=-1 -qarch=auto -qtune=auto -qextname -q64"
> SHLIB_LDFLAGS="-Wl,-G -Wl,-bM:SRE -Wl,-H512 -Wl,-T512 -Wl,-bnoentry
> -Wl,-bexpall"
> CXX=xlC
> CXXFLAGS="-O -qmaxmem=-1 -qarch=auto -qtune=auto -q64"
>
>
>
> Andy
>
>
>
> > From: Frankie Cheung [mailto:ftcheung@hkusua.hku.hk]
> >
> > Dear Sir,
> >
> > Still encounter another error message during compilation of
> R 1.9.1 on
> > AIX 5.1 (target expall not found):
> [snip]
> >
> > Any suggestion?
> >
> > with regards,
> > Frankie Cheung
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide!
> http://www.R-project.org/posting-guide.html
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://www.stat.math.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide!
> http://www.R-project.org/posting-guide.html
>
>



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Tue Jul 20 04:26:17 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:55:05 EST