RE: [R] gcc on AIX is not compatile with R-1.9.1

From: Liaw, Andy <andy_liaw_at_merck.com>
Date: Fri 23 Jul 2004 - 09:58:31 EST


> From: Liao, Kexiao
>
> Hi Uwe Liqqes,
> Does the successful compilation for R-1.9.1 on AIX 5.1
> depend on the
> IBM AIX compiler for C and C++ (xlc/xlC)? gcc on AIX is not compatible
> with R1.9.1.

I believe GCC will work on AIX, but you most likely need a newer version than what you have. I believe the R-admin manual mentioned success with 2.95.

With regard to your other question: You can compile R w/o having any of those. You just won't be able to build the manuals or use the tcltk package. Go through the R-admin manual carefully to see how to build R without tcltk.

Andy  

> Kexiao
>



R-help@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri Jul 23 10:06:38 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:55:11 EST