Re: [R] write a library under 2.0.1 version

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Wed 02 Mar 2005 - 03:14:06 EST

marta@statistica.it wrote:

> Hi there,
> I had written a library

You are talking about a *package*, I guess.

> under R 1.9.0 and now I would like to import that
> library under R 2.0.1

You have to (re-)install it from the sources.

> Apparently it does not work; I can install the package, but when I try to
> read it the error is the following:
>
> Error in library(compvar) : 'compvar' is not a valid package -- installed
> < 2.0.0
 >
> I have checked other libraries in R 2.0.1 and I noticed that there is a
> new folders (Meta) that were not present under R 1.9.1 as well as a file
> (MD5). Moreover, under R folders there are files with .rdx and .rdb
> extensions that were not present before.

Right, lazy loading database.

> I was wondering how I can built these files for the library to be
> importable under 2.0.1 version.

I guess you are under Windows?
Please read the R FAQ, the R for Windows FAQ, the manual "Writing R Extensions" and also ?INSTALL. All of them mention how to install from the package's sources.

Uwe Ligges

>
> Any suggestion?
>
> Cheers,
> Marta
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Mar 02 04:56:49 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:30:39 EST