Re: [R] write a library under 2.0.1 version

From: Paul Roebuck <roebuck_at_odin.mdacc.tmc.edu>
Date: Wed 02 Mar 2005 - 09:47:43 EST

On Tue, 1 Mar 2005, Prof Brian Ripley wrote:

> On Tue, 1 Mar 2005 marta@statistica.it wrote:
>
> > I had written a library under R 1.9.0 and now I would like to import that
> > library under R 2.0.1
> > Apparently it does not work; I can install the package, but when I try to
> > read it the error is the following:
> >
> > Error in library(compvar) : 'compvar' is not a valid package -- installed
> > < 2.0.0
> >
> > [SNIP]
>
> You install the package with R CMD INSTALL, just as was documented for
> 1.9.1. See the `Writing R Extensions' and `R Installation and
> Administration' manuals.

Out of curiousity, just how often has the package installation compatibility between versions been an issue? Would it perhaps be beneficial to version personal directories by major version? I.e. instead of having just "~/R/library", would it be better to have "~/R/1.x/library" and "~/R/2.x/library" and have the .Rprofile select appropriately depending on version of R being executed? If so, maybe this question would cease to be an issue.

I'd be interested to know how Prof. Ripley's R_LIBS variable is defined, if he wouldn't mind sharing. Also curious if most people keep BioConductor packages installed separately in a third location.



SIGSIG -- signature too long (core dumped)

R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Mar 02 10:03:47 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:30:39 EST