Re: [R] missing sh.exe file when running "R CMD INSTALL test"

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Wed 16 Mar 2005 - 06:51:48 EST

On Tue, 15 Mar 2005 14:26:42 -0500, roger bos <roger.bos@gmail.com> wrote :

>I am trying to learn how to make a simple package that contains no C
>or Fortran code. I used package.skeleton(...) to make a package
>called "test". The directory and files look good. I downloaded and
>installed Rtools (www.murdoch-sutherland.com/Rtools/tools.zip). I
>added the path and from the dos prompt I can verify that make.exe and
>sh.exe both exist, but when I try to run "R CMD INSTALL test" I get an
>error "make: sh.exe: Command not found" and "make: *** [pkg-test]
>Error 127". I get the same error message if a try the command "make
>pkg-test".
>
>I saw in an old FAQ a suggestion to move sh.eve to the C:\bin\ folder,
>but my C: root does not have a "bin" folder. Nonetheless, I created
>one and put sh.exe there and it provided no help (I didn't expect it
>too).
>
>Can anyone help me?

It sounds as though your PATH is incomplete. If you just type "sh", does it run? If not, then you need to set up your path to include the R tools directory. It should probably be first in the PATH, as described in README.packages..

bDuncan



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Wed Mar 16 06:58:23 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:30:48 EST