Re: [R] Package under R 2.1.0: package.rds

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Thu 21 Apr 2005 - 06:34:11 EST

huan.huang@uk.bnpparibas.com wrote:

> Hi everybody,
>
> I have trouble installing my own package under R 2.1.0 (it is fine under R
> 2.0.1). My OS is Windows NT.
>
> I installed my package 'mag' by using menu "Packages/Install package from
> local zip files....". It's fine (html package description was updated). But
> when I typed in library(mag) it gave me error:
> Error in library(mag) : there is no package called 'mag'
>
> I traced the library() and found the problem is in meta/package.rds
> I don't have my own package.rds file. I copied the whole meta directory from base package (to make my package work under R 2.0.0). Function
> .find.package() looks up some package information in package.rds file and get the wrong information (info about base rather than mine "mag".
>
> I was trying to make my own package.rds file. I looked up the manual (writing R extension) and R help archives and can't find relevant information.
> Can anybody point me the way to it please?

Simply install your package from sources again using

   R CMD INSTALL package
All required files will be generated automatically.

I wonder why it worked in 2.0.x - I guess it was 1.x.y when it worked the last time.

Uwe Ligges

> Many many thanks,
> Huan
>
>
>
> This message and any attachments (the "message") is\ intende...{{dropped}}
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Thu Apr 21 06:41:29 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:18 EST