Re: [R] Problem with R-2.1.0: install.packages() doesn't work

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Sat 23 Apr 2005 - 01:48:15 EST

Waichler, Scott R wrote:

> I installed R-2.1.0 from source on a Linux box running Red Hat
> Enterprise Linux WS release 4 but install.packages() wouldn't work (see
> below). When I install R-2.0.1 from RPM on the same system, everything
> is fine.
>
> Version 2.1.0 (2005-04-18), ISBN 3-900051-07-0
> . . .
>
>>options(CRAN = "http://cran.fhcrc.org/")

options(CRAN = ...) is outdated. See ?options.

>>install.packages("rgenoud")

>
> --- Please select a CRAN mirror for use in this session ---
> Error in inherits(x, "factor") : Object "res" not found

Quite probably you have no X11 connection to this machine. R tries to ask you which CRAN mirror you are going to choose, and it fails to present the tcltk window.
You might want to call

   chooseCRANmirror(graphics=FALSE)
and

   setRepositories(graphics=FALSE)
prior to install.packages().

Uwe Ligges

>
> Scott Waichler
> Pacific Northwest National Laboratory
> scott.waichler@pnl.gov
>
> ______________________________________________
> R-help@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Apr 23 01:59:14 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:22 EST