Re: [R] libz library missing while installing RMySQL

From: Jari Oksanen <jarioksa_at_sun3.oulu.fi>
Date: Wed 27 Apr 2005 - 18:40:47 EST

On Wed, 2005-04-27 at 09:43 +0200, Sebastian Leuzinger wrote:
> Hello
> Trying to install the MySQL package, I get the following error. The help
> archive contains something on this issue but did not help. I work on linux
> suse 9.3
>
> Configuration error:
> Could not locate the library "libz" required by MySQL.
>
> The library libz however is not on any mirrors I checked.

Sebastian, You made some R core people very happy: they have tried very hard to explain that there is a difference between a *library* and a *package*, and that this difference really matters. This seems to be the first case on R-News when this distinction really seems to matter: you need a library. I don't know about SuSE (or with some other really weird capitalization), but in my system libz belongs to package zlib that you must install, and in my system you'd probably need zlib-devel as well (this is FC3). So they are system level libraries that come with SuSe instead of R packages.

cheers, jari oksanen

-- 
Jari Oksanen <jarioksa@sun3.oulu.fi>

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html
Received on Wed Apr 27 18:47:02 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:27 EST