RE: [R] R-2.1.0 search engine works with mozilla browser but not firefox

From: Waichler, Scott R <Scott.Waichler_at_pnl.gov>
Date: Sat 30 Apr 2005 - 04:34:37 EST

  

> > I'm running R-2.1.0 on a Linux box and found that the HTML search
> > engine help would not work with Firefox 1.0.3 but would work with
> > Mozilla 1.7.7. I have Java Runtime Environment 1.5.0_02
> installed.
> > With Firefox, when I launch help.start() and click to the search
> > engine, it brings up the first page with "Applet
> SearchEngine started"
> > in the status bar, but clicking on one of the contents entries or
> > trying to search for a term does nothing.

> It works with Firefox 1.0.3 for me on Fedora Core 3.
>
> Please consult the appropriate manual as linked from the
> search page: this is a configuration issue local to you. One
> irritating part of FC3's updates is that they do not (at
> least for me) copy the plugins across, so I had manually to
> fix up my Firefox 1.0.3 update yesterday. Sounds like your
> plugin is not set up correctly.

I followed the advice posted at
http://plugindoc.mozdev.org/faqs/java.html#Linux to install the JRE plugin correctly:

"If you installed the JRE 5.0 RPM, this plugin is /usr/java/j2re1.5.0/plugin/i386/ns7/libjavaplugin_oji.so - and to install it for Mozilla (including Mozilla Firefox), do the following:

Important! If you install your JRE in a different way (self extracting package, debian package, etc), libjavaplugin_oji.so will quite likely be in a different location. Do not just blindly use the command listed above!"

All of this checked out for me, and Firefox still won't work with R's search engine. Yes, I understand this isn't an R issue per se, but I don't know where to turn. . .

Scott Waichler



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Sat Apr 30 04:38:55 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:31 EST