[R] Installing RMySQL on Mac OS X

From: Thomas Koepsell <koepsell_at_u.washington.edu>
Date: Fri 13 May 2005 - 02:06:11 EST

I could really use some advice about installing the RMySQL package under R 2.1.0 on Mac OS 10.4. I get the following message from R when I try:



Configuration error:

    Could not locate the library "libz" required by MySQL.

INSTRUCTIONS:     The "libz" library is required by the MySQL client library     in order to compress/uncompress connections between clients     and the MySQL engine.

    Make sure you have "libz" installed properly and/or included     in your $LD_LIBRARY_PATH. Perhaps it is not in any of the     standard directories (e.g., /usr/lib/, /usr/local/lib)?

Aborting the installation of RMySQL.

ERROR: configuration failed for package 'RMySQL'


The above message notwithstanding, files that appear in /usr/lib/ on my machine include:

   libz.1.1.3.dylib        libz.1.dylib
   libz.1.2.2.dylib        libz.dylib

so libz appears to be there.

An earlier suggestion on this list about changing the environment variables PKG_CPPFLAGS and PKG_LIBS had no effect, unfortunately.

I installed R 2.1.0 from a binary download. The required DBI package is installed. A binary version of RMySQL is not available for Macs, so I am trying to install RMySQL from sources. Before getting Mac OS 10.4, I tried the same installation under 10.3 and 10.2 and had the same problem, and also with R 2.0.1.

I know others have working installations of RMySQL on their Mac OS X systems. Any tips for getting there would be most welcome. Thanks!

Tom Koepsell



R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Fri May 13 02:11:54 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:44 EST