[R] source-only package, but still: Error: package 'simple' was built for powerpc-apple-darwin7.9.0

From: Paul Shannon <pshannon_at_systemsbiology.org>
Date: Thu 19 May 2005 - 08:18:10 EST


I have a number simple R functions written for the biologists I work with. These functions will evolve, and the documentation will get steadily better. I hope to put them in a package on a local webserver, along with lots of help files, so that the users can easily update their installation.

The functions are pure R, with no compiled code, but alias, I cannot figure out how to build this package so that it is portable across operating systems.

It looks like 'R CMD build' inserts the following line into the resulting package:

     Built: R 2.1.0; powerpc-apple-darwin7.9.0; 2005-05-18 14:28:36; unix

making it impossible for me to later load the package into R running under another OS. I see this error when I execute library ('simple') under linux:

   Error: package 'simple' was built for powerpc-apple-darwin7.9.0

I'll be grateful if anyone can help me work around this restriction ... or let me know how I am misconstruing the evidence.

Thank you!


R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide! http://www.R-project.org/posting-guide.html Received on Thu May 19 08:29:24 2005

This archive was generated by hypermail 2.1.8 : Fri 03 Mar 2006 - 03:31:50 EST